summaryrefslogtreecommitdiffstats
path: root/docs/index.rst
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:20:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:20:41 +0000
commitb49f1524e250764592ff132af8fb0d39182620f7 (patch)
treea2c4da0c1bfc3be79c9b80180d8958804e91a07d /docs/index.rst
parentInitial commit. (diff)
downloadpython-build-upstream/0.9.0.tar.xz
python-build-upstream/0.9.0.zip
Adding upstream version 0.9.0.upstream/0.9.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'docs/index.rst')
-rw-r--r--docs/index.rst54
1 files changed, 54 insertions, 0 deletions
diff --git a/docs/index.rst b/docs/index.rst
new file mode 100644
index 0000000..f13aa7a
--- /dev/null
+++ b/docs/index.rst
@@ -0,0 +1,54 @@
+:hide-toc:
+
+*****
+build
+*****
+
+A simple, correct :pep:`517` build frontend.
+
+build will invoke the :pep:`517` hooks to build a distribution package.
+It is a simple build tool and does not perform any dependency management.
+
+.. sphinx_argparse_cli::
+ :module: build.__main__
+ :func: main_parser
+ :prog: python -m build
+ :title: python -m build
+ :usage_width: 97
+
+.. note::
+
+ A ``pyproject-build`` CLI script is also available, so that tools such as pipx_
+ can use it.
+
+By default build will build the package in an isolated
+environment, but this behavior can be disabled with ``--no-isolation``.
+
+.. toctree::
+ :hidden:
+
+ mission
+ differences
+
+.. toctree::
+ :caption: Usage
+ :hidden:
+
+ installation
+ changelog
+ api
+
+.. toctree::
+ :caption: Contributing
+ :hidden:
+
+ test_suite
+
+.. toctree::
+ :caption: Project Links
+ :hidden:
+
+ Source Code <https://github.com/pypa/build/>
+ Issue Tracker <https://github.com/pypa/build/issues>
+
+.. _pipx: https://github.com/pipxproject/pipx