summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..75cfb14
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+# export DH_VERBOSE = 1
+
+export PYBUILD_NAME = installer
+
+export PYBUILD_TEST_ARGS = -rsx -v
+
+%:
+ dh $@ --buildsystem pybuild
+
+execute_after_dh_auto_build:
+ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
+ PYTHONPATH=$(CURDIR)/src/ \
+ http_proxy=http://127.0.0.1:9 \
+ https_proxy=https://127.0.0.1:9 \
+ python3 -m sphinx -N -bhtml docs/ build/html
+endif