summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..ba0f48b
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,21 @@
+[build-system]
+requires = ["flit_core >=3.2.0,<4"]
+build-backend = "flit_core.buildapi"
+
+[project]
+name = "installer"
+authors = [
+ { name = "Pradyun Gedam", email = "pradyunsg@gmail.com" },
+]
+readme = "README.md"
+classifiers = [
+ "License :: OSI Approved :: MIT License",
+]
+requires-python = ">=3.7"
+dynamic = [
+ "version",
+ "description",
+]
+
+[project.urls]
+"GitHub" = "https://github.com/pypa/installer"