summaryrefslogtreecommitdiffstats
path: root/tests/roots/test-setup
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 11:31:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 11:31:33 +0000
commite863fd965dd6253243c3342bd6f0adc4fc8aec4d (patch)
treea4c1b6491a82593950043c3f8b2530e80664d768 /tests/roots/test-setup
parentInitial commit. (diff)
downloadsphinx-e863fd965dd6253243c3342bd6f0adc4fc8aec4d.tar.xz
sphinx-e863fd965dd6253243c3342bd6f0adc4fc8aec4d.zip
Adding upstream version 5.3.0.upstream/5.3.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/roots/test-setup')
-rw-r--r--tests/roots/test-setup/doc/conf.py4
-rw-r--r--tests/roots/test-setup/doc/index.txt5
-rw-r--r--tests/roots/test-setup/setup.cfg5
-rw-r--r--tests/roots/test-setup/setup.py10
4 files changed, 24 insertions, 0 deletions
diff --git a/tests/roots/test-setup/doc/conf.py b/tests/roots/test-setup/doc/conf.py
new file mode 100644
index 0000000..f4dc6d6
--- /dev/null
+++ b/tests/roots/test-setup/doc/conf.py
@@ -0,0 +1,4 @@
+project = 'Sphinx smallest project'
+source_suffix = '.txt'
+keep_warnings = True
+exclude_patterns = ['_build']
diff --git a/tests/roots/test-setup/doc/index.txt b/tests/roots/test-setup/doc/index.txt
new file mode 100644
index 0000000..56960f5
--- /dev/null
+++ b/tests/roots/test-setup/doc/index.txt
@@ -0,0 +1,5 @@
+contents
+=========
+
+spam egg ham
+
diff --git a/tests/roots/test-setup/setup.cfg b/tests/roots/test-setup/setup.cfg
new file mode 100644
index 0000000..cf2a7f5
--- /dev/null
+++ b/tests/roots/test-setup/setup.cfg
@@ -0,0 +1,5 @@
+[build_sphinx]
+project = 'My project'
+version = 1.2
+release = 1.2.0
+source-dir = doc
diff --git a/tests/roots/test-setup/setup.py b/tests/roots/test-setup/setup.py
new file mode 100644
index 0000000..efff6f2
--- /dev/null
+++ b/tests/roots/test-setup/setup.py
@@ -0,0 +1,10 @@
+from setuptools import setup
+
+from sphinx.setup_command import BuildDoc
+
+cmdclass = {'build_sphinx': BuildDoc}
+
+setup(
+ name='sphinxdoc',
+ cmdclass=cmdclass,
+)