summaryrefslogtreecommitdiffstats
path: root/debian/patches/p11kit-switch-to-dlopen.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 10:23:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 10:23:37 +0000
commit56e54b2fe49aafc989c8e21dcd2c986b6e6106a0 (patch)
tree6406820e2c9516fdc4f1bad1da979450d95b7e91 /debian/patches/p11kit-switch-to-dlopen.patch
parentMerging upstream version 252.23. (diff)
downloadsystemd-56e54b2fe49aafc989c8e21dcd2c986b6e6106a0.tar.xz
systemd-56e54b2fe49aafc989c8e21dcd2c986b6e6106a0.zip
Merging debian version 252.23-1~deb12u1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--debian/patches/p11kit-switch-to-dlopen.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/patches/p11kit-switch-to-dlopen.patch b/debian/patches/p11kit-switch-to-dlopen.patch
index b22bf58..ed9cbf2 100644
--- a/debian/patches/p11kit-switch-to-dlopen.patch
+++ b/debian/patches/p11kit-switch-to-dlopen.patch
@@ -13,7 +13,7 @@ Subject: p11kit: switch to dlopen()
7 files changed, 202 insertions(+), 60 deletions(-)
diff --git a/meson.build b/meson.build
-index 9de2309..27d95e7 100644
+index afcb4a7..e707742 100644
--- a/meson.build
+++ b/meson.build
@@ -1462,8 +1462,10 @@ if want_p11kit != 'false' and not skip_deps
@@ -718,10 +718,10 @@ index 85dbb81..55728c2 100644
}
diff --git a/test/test-functions b/test/test-functions
-index 73fbef8..0ba7ce2 100644
+index da17bff..58257d4 100644
--- a/test/test-functions
+++ b/test/test-functions
-@@ -1386,7 +1386,7 @@ install_missing_libraries() {
+@@ -1391,7 +1391,7 @@ install_missing_libraries() {
local lib path
# A number of dependencies is now optional via dlopen, so the install
# script will not pick them up, since it looks at linkage.
@@ -730,7 +730,7 @@ index 73fbef8..0ba7ce2 100644
ddebug "Searching for $lib via pkg-config"
if pkg-config --exists "$lib"; then
path="$(pkg-config --variable=libdir "$lib")"
-@@ -1398,6 +1398,10 @@ install_missing_libraries() {
+@@ -1403,6 +1403,10 @@ install_missing_libraries() {
if ! [[ ${lib} =~ ^lib ]]; then
lib="lib${lib}"
fi