summaryrefslogtreecommitdiffstats
path: root/make_version_h.pl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 15:45:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 15:45:37 +0000
commite0801e6bd6cc1241afafea33ba8ef701fec2e5c5 (patch)
treeb5cf84f45181b3dbc14d58833d88683fb7f3465e /make_version_h.pl
parentInitial commit. (diff)
downloadwhois-e0801e6bd6cc1241afafea33ba8ef701fec2e5c5.tar.xz
whois-e0801e6bd6cc1241afafea33ba8ef701fec2e5c5.zip
Adding upstream version 5.5.17.upstream/5.5.17upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'make_version_h.pl')
-rwxr-xr-xmake_version_h.pl29
1 files changed, 29 insertions, 0 deletions
diff --git a/make_version_h.pl b/make_version_h.pl
new file mode 100755
index 0000000..ae4a69b
--- /dev/null
+++ b/make_version_h.pl
@@ -0,0 +1,29 @@
+#!/usr/bin/perl
+
+use warnings;
+use strict;
+use autodie;
+
+my $changelog = $ARGV[0] or die "Usage: $0 debian/changelog\n";
+
+open(my $fh, '<', $changelog);
+my $line = <$fh>;
+close($fh);
+
+my ($ver) = $line =~ /^whois \s+ \( ( [^\)]+ ) \) \s+ \S+/x;
+die "Version number not found in $changelog!\n" if not $ver;
+
+$ver =~ s/ ( ~bpo\d+\+\d+ | \+b\d+ | ~deb\d+.* | ubuntu\d+ | build\d+ | \+dyson\d+ ) $//x;
+
+# The version number must not deviate from this format or the -V option
+# to RIPE-like servers will break. If needed, update the previous regexp.
+# This may not be true anymore in 2019.
+die "Invalid version number in $changelog!\n"
+ unless $ver =~ /^ \d+\.\d+ ( \.\d+ )? $/x;
+
+# This is the version number used in the help messages.
+print qq|#define VERSION "$ver"\n|;
+
+# This is the string sent to RIPE-like servers as the argument of -V.
+print qq|#define IDSTRING "Md$ver"\n|;
+