summaryrefslogtreecommitdiffstats
path: root/xdp-monitor/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 07:10:00 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 07:10:00 +0000
commit4ba2b326284765e942044db13a7f0dae702bec93 (patch)
treecbdfaec33eed4f3a970c54cd10e8ddfe3003b3b1 /xdp-monitor/Makefile
parentInitial commit. (diff)
downloadxdp-tools-4ba2b326284765e942044db13a7f0dae702bec93.tar.xz
xdp-tools-4ba2b326284765e942044db13a7f0dae702bec93.zip
Adding upstream version 1.3.1.upstream/1.3.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'xdp-monitor/Makefile')
-rw-r--r--xdp-monitor/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/xdp-monitor/Makefile b/xdp-monitor/Makefile
new file mode 100644
index 0000000..5b646fa
--- /dev/null
+++ b/xdp-monitor/Makefile
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: (GPL-2.0 OR BSD-2-Clause)
+
+XDP_TARGETS := xdp_monitor.bpf
+BPF_SKEL_TARGETS := $(XDP_TARGETS)
+
+# Don't install skeleton object files
+XDP_OBJ_INSTALL :=
+
+TOOL_NAME := xdp-monitor
+MAN_PAGE := xdp-monitor.8
+TEST_FILE := tests/test-xdp-monitor.sh
+USER_TARGETS := xdp-monitor
+LIB_DIR = ../lib
+
+include $(LIB_DIR)/common.mk
+