summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xdebian/rules16
1 files changed, 2 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index 7497f1d..ceabf38 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,8 @@ ifneq (,$(filter $(DEB_HOST_MULTIARCH), mips64el-linux-gnuabi64 mipsel-linux-gnu
export BPF_CFLAGS+= -D__MIPSEL__=1
endif
+export BPFTOOL=/usr/sbin/bpftool
+
ifneq (,$(findstring terse,$(DEB_BUILD_OPTIONS)))
export VERBOSE=0
else
@@ -23,17 +25,3 @@ endif
# Tests require root and break the testbed
override_dh_auto_test:
-
-execute_before_dh_auto_build:
- # On Ubuntu, the `bpftool` in path is a shell wrapper pointing at
- # the binary corresponding to runtime kernel version.
- #
- # We do not know the kernel version being used on the system building
- # this package, and for the build we only need the tool to generate
- # skeleton code.
- #
- # If /usr/lib/linux-tools-*/bpftool exists, locate the most recent
- # version and point to that, otherwise `bpftool` from PATH will be
- # used.
- for _bpftool in $(ls /usr/lib/linux-tools-*/bpftool); do true;done
- if [ -x "$_bpftool" ]; then export BPFTOOL=$_bpftool; fi