summaryrefslogtreecommitdiffstats
path: root/lib/testing/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--lib/testing/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/testing/Makefile b/lib/testing/Makefile
new file mode 100644
index 0000000..8d5c153
--- /dev/null
+++ b/lib/testing/Makefile
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: (GPL-2.0 OR BSD-2-Clause)
+
+TEST_TARGETS := test-tool
+XDP_TARGETS := test_long_func_name xdp_drop xdp_pass
+SCRIPTS_FILES := test_runner.sh setup-netns-env.sh run_tests.sh
+XDP_OBJ_INSTALL :=
+
+LIB_DIR = ..
+
+include $(LIB_DIR)/common.mk
+
+install_local::
+ install -m 0755 -d $(DESTDIR)$(SCRIPTSDIR)
+ install -m 0644 test_config.install.sh $(DESTDIR)$(SCRIPTSDIR)/test_config.sh
+ install -m 0644 $(XDP_OBJ) $(DESTDIR)$(SCRIPTSDIR)/