summaryrefslogtreecommitdiffstats
path: root/xdp-trafficgen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'xdp-trafficgen/Makefile')
-rw-r--r--xdp-trafficgen/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/xdp-trafficgen/Makefile b/xdp-trafficgen/Makefile
new file mode 100644
index 0000000..4a6892e
--- /dev/null
+++ b/xdp-trafficgen/Makefile
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: (GPL-2.0 OR BSD-2-Clause)
+
+XDP_TARGETS := xdp_trafficgen.bpf
+BPF_SKEL_TARGETS := $(XDP_TARGETS)
+
+# Don't install skeleton object files
+XDP_OBJ_INSTALL :=
+
+TOOL_NAME := xdp-trafficgen
+USER_TARGETS := xdp-trafficgen
+MAN_PAGE := xdp-trafficgen.8
+EXTRA_DEPS := xdp-trafficgen.h
+USER_LIBS = -lpthread
+TEST_FILE := tests/test-xdp-trafficgen.sh
+
+LIB_DIR = ../lib
+
+include $(LIB_DIR)/common.mk
+