summaryrefslogtreecommitdiffstats
path: root/bin/tests/system/runall.sh
diff options
context:
space:
mode:
Diffstat (limited to 'bin/tests/system/runall.sh')
-rwxr-xr-xbin/tests/system/runall.sh76
1 files changed, 38 insertions, 38 deletions
diff --git a/bin/tests/system/runall.sh b/bin/tests/system/runall.sh
index 0391633..9d6f037 100755
--- a/bin/tests/system/runall.sh
+++ b/bin/tests/system/runall.sh
@@ -39,29 +39,29 @@ SYSTEMTEST_NO_CLEAN=${SYSTEMTEST_NO_CLEAN:-0}
# Handle command line switches if present.
while getopts "cn" flag; do
- case "$flag" in
- c) SYSTEMTEST_FORCE_COLOR=1 ;;
- n) SYSTEMTEST_NO_CLEAN=1 ;;
- esac
+ case "$flag" in
+ c) SYSTEMTEST_FORCE_COLOR=1 ;;
+ n) SYSTEMTEST_NO_CLEAN=1 ;;
+ esac
done
export NOCLEAN
-shift `expr $OPTIND - 1`
+shift $(expr $OPTIND - 1)
# Obtain number of processes to use.
if [ $# -eq 0 ]; then
- numproc=1
+ numproc=1
elif [ $# -eq 1 ]; then
- test "$1" -eq "$1" > /dev/null 2>&1
- if [ $? -ne 0 ]; then
- # Value passed is not numeric
- echo "$usage" >&2
- exit 1
- fi
- numproc=$1
-else
+ test "$1" -eq "$1" >/dev/null 2>&1
+ if [ $? -ne 0 ]; then
+ # Value passed is not numeric
echo "$usage" >&2
exit 1
+ fi
+ numproc=$1
+else
+ echo "$usage" >&2
+ exit 1
fi
# Run the tests.
@@ -72,36 +72,36 @@ export SYSTEMTEST_NO_CLEAN
status=0
if [ "$NOPARALLEL" = "" ]; then
- if [ "$CYGWIN" = "" ]; then
- # Running on Unix, use "make" to run tests in parallel.
- make -j $numproc check
- status=$?
- else
- # Running on Windows: Cygwin "make" is available, but isn't being
- # used for the build. So we create a special makefile for the purpose
- # of parallel execution of system tests, and use that.
- $SHELL parallel.sh > parallel.mk
- make -f parallel.mk -j $numproc check
- $SHELL ./runsequential.sh
- $SHELL ./testsummary.sh || status=1
- fi
+ if [ "$CYGWIN" = "" ]; then
+ # Running on Unix, use "make" to run tests in parallel.
+ make -j $numproc check
+ status=$?
+ else
+ # Running on Windows: Cygwin "make" is available, but isn't being
+ # used for the build. So we create a special makefile for the purpose
+ # of parallel execution of system tests, and use that.
+ $SHELL parallel.sh >parallel.mk
+ make -f parallel.mk -j $numproc check
+ $SHELL ./runsequential.sh
+ $SHELL ./testsummary.sh || status=1
+ fi
else
- # the NOPARALLEL environment variable indicates that tests must be
- # run sequentially.
- $PERL testsock.pl || {
- cat <<-EOF
+ # the NOPARALLEL environment variable indicates that tests must be
+ # run sequentially.
+ $PERL testsock.pl || {
+ cat <<-EOF
I:NOTE: System tests were skipped because they require the
I: test IP addresses 10.53.0.* to be configured as alias
I: addresses on the loopback interface. Please run
I: "bin/tests/system/ifconfig.sh up" as root to configure them.
EOF
- exit 1
- }
- {
- for testdir in $SUBDIRS; do
- $SHELL run.sh $testdir || status=1
- done
- } 2>&1 | tee "systests.output"
+ exit 1
+ }
+ {
+ for testdir in $SUBDIRS; do
+ $SHELL run.sh $testdir || status=1
+ done
+ } 2>&1 | tee "systests.output"
fi
exit $status