summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:07:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:07:23 +0000
commit4e1432299981d8a5a5f69114476645f30b3d42e0 (patch)
tree73bb8cf8ccab0e787c147ddb4bc4ab793d586842 /debian/rules
parentAdding upstream version 3.38.6. (diff)
downloadgnome-shell-debian/3.38.6-1_deb11u1.tar.xz
gnome-shell-debian/3.38.6-1_deb11u1.zip
Adding debian version 3.38.6-1~deb11u1.debian/3.38.6-1_deb11u1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1a9056c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
+
+%:
+ dh $@ --with bash_completion
+
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+CONFFLAGS = \
+ -Dnetworkmanager=true \
+ -Dsystemd=true
+endif
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --libdir=/usr/lib \
+ -Dbash_completion=true \
+ $(CONFFLAGS)
+
+override_dh_makeshlibs:
+ dh_makeshlibs -X/usr/lib/gnome-shell/
+
+override_dh_shlibdeps:
+ # gnome-shell uses mutters private mutter-clutter-1.0.so etc.
+ dh_shlibdeps -l"usr/lib/$(DEB_HOST_MULTIARCH)/mutter"
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ dbus-run-session xvfb-run -a dh_auto_test
+endif