summaryrefslogtreecommitdiffstats
path: root/bin/moveglobalheaders.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /bin/moveglobalheaders.sh
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'bin/moveglobalheaders.sh')
-rwxr-xr-xbin/moveglobalheaders.sh43
1 files changed, 43 insertions, 0 deletions
diff --git a/bin/moveglobalheaders.sh b/bin/moveglobalheaders.sh
new file mode 100755
index 000000000..ca202832b
--- /dev/null
+++ b/bin/moveglobalheaders.sh
@@ -0,0 +1,43 @@
+#!/bin/bash
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+topdirs=`find . -mindepth 1 -maxdepth 1 -type d -not -name sal`
+mkdir -p include/
+for dir in $topdirs
+do
+ dir=`echo "$dir"| sed -e 's/^..//'`
+ if test -d $dir/inc/$dir
+ then
+ if test -f $dir/Package_inc.mk
+ then
+ if test -f $dir/Module_$dir.mk
+ then
+ git mv $dir/inc/$dir include/$dir
+ git rm $dir/Package_inc.mk
+ grep -v Package_inc $dir/Module_$dir.mk > $dir/Module_dir.mk.new
+ mv -f $dir/Module_dir.mk.new $dir/Module_$dir.mk
+ git add $dir/Module_$dir.mk
+ else
+ echo "WARN: no $dir/Module_$dir.mk"
+ fi
+ else
+ echo "WARN: no file $dir/Package_inc.mk"
+ fi
+ fi
+done
+#grep -v Package_inc.mk sal/CustomTarget_sal_allheaders.mk > sal/CustomTarget_sal_allheaders.mk.new
+#mv sal/CustomTarget_sal_allheaders.mk.new sal/CustomTarget_sal_allheaders.mk
+#git add sal/CustomTarget_sal_allheaders.mk
+
+# we like to be special ...
+sed -ie 's/\/svtools\/inc\/svtools/\/include\/svtools\//' svtools/Library_svt.mk
+sed -ie 's/\/sfx2\/inc\/sfx2/\/include\/sfx2\//' sfx2/Library_sfx.mk
+git add svtools/Library_svt.mk sfx2/Library_sfx.mk
+
+# urgh
+sed -ie 's/\.\.\/svx\//svx\//' svx/source/svdraw/svdoashp.cxx
+git add svx/source/svdraw/svdoashp.cxx