summaryrefslogtreecommitdiffstats
path: root/cppcanvas/CppunitTest_cppcanvas_emfplus.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /cppcanvas/CppunitTest_cppcanvas_emfplus.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--cppcanvas/CppunitTest_cppcanvas_emfplus.mk65
1 files changed, 65 insertions, 0 deletions
diff --git a/cppcanvas/CppunitTest_cppcanvas_emfplus.mk b/cppcanvas/CppunitTest_cppcanvas_emfplus.mk
new file mode 100644
index 000000000..ee47d8af0
--- /dev/null
+++ b/cppcanvas/CppunitTest_cppcanvas_emfplus.mk
@@ -0,0 +1,65 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,cppcanvas_emfplus))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,cppcanvas_emfplus, \
+ cppcanvas/qa/extras/emfplus/emfplus \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,cppcanvas_emfplus, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ sfx \
+ subsequenttest \
+ test \
+ tl \
+ unotest \
+ vcl \
+))
+
+$(eval $(call gb_CppunitTest_use_external,cppcanvas_emfplus,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,cppcanvas_emfplus))
+
+$(eval $(call gb_CppunitTest_use_ure,cppcanvas_emfplus))
+$(eval $(call gb_CppunitTest_use_vcl_non_headless,cppcanvas_emfplus))
+
+$(eval $(call gb_CppunitTest_use_components,cppcanvas_emfplus,\
+ canvas/source/cairo/cairocanvas \
+ canvas/source/factory/canvasfactory \
+ cppcanvas/source/uno/mtfrenderer \
+ configmgr/source/configmgr \
+ emfio/emfio \
+ extensions/source/scanner/scn \
+ filter/source/config/cache/filterconfig1 \
+ framework/util/fwk \
+ i18npool/util/i18npool \
+ package/util/package2 \
+ sax/source/expatwrap/expwrap \
+ sfx2/util/sfx \
+ sd/util/sd \
+ sd/util/sdd \
+ svl/source/fsstor/fsstorage \
+ toolkit/util/tk \
+ vcl/vcl.common \
+ ucb/source/core/ucb1 \
+ ucb/source/ucp/file/ucpfile1 \
+ unoxml/source/service/unoxml \
+ uui/util/uui \
+ svtools/util/svt \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,cppcanvas_emfplus))
+
+# vim: set noet sw=4 ts=4: