summaryrefslogtreecommitdiffstats
path: root/desktop/CustomTarget_soffice.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /desktop/CustomTarget_soffice.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/CustomTarget_soffice.mk')
-rw-r--r--desktop/CustomTarget_soffice.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/desktop/CustomTarget_soffice.mk b/desktop/CustomTarget_soffice.mk
new file mode 100644
index 000000000..1fa356db1
--- /dev/null
+++ b/desktop/CustomTarget_soffice.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,desktop/soffice))
+
+$(call gb_CustomTarget_get_target,desktop/soffice) : \
+ $(call gb_CustomTarget_get_workdir,desktop/soffice)/soffice.sh
+
+$(call gb_CustomTarget_get_workdir,desktop/soffice)/soffice.sh : \
+ $(SRCDIR)/desktop/scripts/soffice.sh \
+ | $(call gb_CustomTarget_get_workdir,desktop/soffice)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),SED,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),SED)
+ifneq ($(JITC_PROCESSOR_TYPE),)
+ sed -e "s/^#@JITC_PROCESSOR_TYPE_EXPORT@/export JITC_PROCESSOR_TYPE=$(JITC_PROCESSOR_TYPE)/" $< > $@
+else
+ cp $< $@
+endif
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),SED)
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: