summaryrefslogtreecommitdiffstats
path: root/desktop/Extension_test-passive.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /desktop/Extension_test-passive.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--desktop/Extension_test-passive.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/desktop/Extension_test-passive.mk b/desktop/Extension_test-passive.mk
new file mode 100644
index 000000000..ef42f3b1b
--- /dev/null
+++ b/desktop/Extension_test-passive.mk
@@ -0,0 +1,35 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Extension_Extension,test-passive,desktop/test/deployment/passive,nodeliver))
+
+$(eval $(call gb_Extension_add_file,test-passive,generic.components,$(call gb_Rdb_get_target,passive_generic)))
+
+$(eval $(call gb_Extension_add_file,test-passive,platform.components,$(call gb_Rdb_get_target,passive_platform)))
+
+$(eval $(call gb_Extension_add_files,test-passive,, \
+ $(SRCDIR)/desktop/test/deployment/passive/Addons.xcu \
+ $(SRCDIR)/desktop/test/deployment/passive/ProtocolHandler.xcu \
+ $(SRCDIR)/desktop/test/deployment/passive/passive_python.py \
+ $(call gb_Jar_get_target,passive_java) \
+))
+
+$(eval $(call gb_Extension_add_files,test-passive,help/en, \
+ $(SRCDIR)/desktop/test/deployment/passive/help/en/help.tree \
+))
+
+$(eval $(call gb_Extension_add_files,test-passive,help/en/org.openoffice%2Fframework%2Fdesktop%2Ftest%2Fdeployment%2Fpassive, \
+ $(SRCDIR)/desktop/test/deployment/passive/help/en/main.xhp \
+))
+
+$(eval $(call gb_Extension_add_libraries,test-passive, \
+ passive_native \
+))
+
+# vim: set noet sw=4 ts=4: