summaryrefslogtreecommitdiffstats
path: root/desktop/UIConfig_deployment.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /desktop/UIConfig_deployment.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/UIConfig_deployment.mk')
-rw-r--r--desktop/UIConfig_deployment.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/desktop/UIConfig_deployment.mk b/desktop/UIConfig_deployment.mk
new file mode 100644
index 000000000..80e5e96c1
--- /dev/null
+++ b/desktop/UIConfig_deployment.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UIConfig_UIConfig,desktop))
+
+$(eval $(call gb_UIConfig_add_uifiles,desktop,\
+ desktop/uiconfig/ui/dependenciesdialog \
+ desktop/uiconfig/ui/extensionmanager \
+ desktop/uiconfig/ui/extensionmenu \
+ desktop/uiconfig/ui/installforalldialog \
+ desktop/uiconfig/ui/licensedialog \
+ desktop/uiconfig/ui/showlicensedialog \
+ desktop/uiconfig/ui/updatedialog \
+ desktop/uiconfig/ui/updateinstalldialog \
+ desktop/uiconfig/ui/updaterequireddialog \
+))
+
+# vim: set noet sw=4 ts=4: