summaryrefslogtreecommitdiffstats
path: root/lingucomponent/Library_lnth.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /lingucomponent/Library_lnth.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'lingucomponent/Library_lnth.mk')
-rw-r--r--lingucomponent/Library_lnth.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/lingucomponent/Library_lnth.mk b/lingucomponent/Library_lnth.mk
new file mode 100644
index 000000000..1351a2f40
--- /dev/null
+++ b/lingucomponent/Library_lnth.mk
@@ -0,0 +1,48 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,lnth))
+
+$(eval $(call gb_Library_set_componentfile,lnth,lingucomponent/source/thesaurus/libnth/lnth))
+
+$(eval $(call gb_Library_set_include,lnth,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/lingucomponent/source/lingutil \
+))
+
+$(eval $(call gb_Library_use_sdk_api,lnth))
+
+$(eval $(call gb_Library_use_libraries,lnth,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ lng \
+ sal \
+ tl \
+ utl \
+))
+
+$(eval $(call gb_Library_use_static_libraries,lnth,\
+ ulingu \
+))
+
+$(eval $(call gb_Library_use_externals,lnth,\
+ boost_headers \
+ hunspell \
+ mythes \
+))
+
+$(eval $(call gb_Library_add_exception_objects,lnth,\
+ lingucomponent/source/thesaurus/libnth/nthesdta \
+ lingucomponent/source/thesaurus/libnth/nthesimp \
+))
+
+# vim: set noet sw=4 ts=4: