summaryrefslogtreecommitdiffstats
path: root/ridljar/JunitTest_connections.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /ridljar/JunitTest_connections.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ridljar/JunitTest_connections.mk')
-rw-r--r--ridljar/JunitTest_connections.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/ridljar/JunitTest_connections.mk b/ridljar/JunitTest_connections.mk
new file mode 100644
index 000000000..8c8496e35
--- /dev/null
+++ b/ridljar/JunitTest_connections.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_JunitTest_JunitTest,ridl_connections))
+
+$(eval $(call gb_Jar_use_customtargets,ridl_connections, \
+ ridljar/javamaker \
+))
+
+$(eval $(call gb_JunitTest_use_jar_classset,ridl_connections,libreoffice))
+
+$(eval $(call gb_JunitTest_add_classpath,ridl_connections,$(call gb_CustomTarget_get_workdir,ridljar/javamaker)))
+
+$(eval $(call gb_JunitTest_add_sourcefiles,ridl_connections,\
+ ridljar/test/com/sun/star/comp/connections/PipedConnection_Test \
+))
+
+$(eval $(call gb_JunitTest_add_classes,ridl_connections,\
+ com.sun.star.comp.connections.PipedConnection_Test \
+))
+
+# vim:set noet sw=4 ts=4: