summaryrefslogtreecommitdiffstats
path: root/scripting/Module_scripting.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /scripting/Module_scripting.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripting/Module_scripting.mk')
-rw-r--r--scripting/Module_scripting.mk50
1 files changed, 50 insertions, 0 deletions
diff --git a/scripting/Module_scripting.mk b/scripting/Module_scripting.mk
new file mode 100644
index 000000000..1d603d585
--- /dev/null
+++ b/scripting/Module_scripting.mk
@@ -0,0 +1,50 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,scripting))
+
+ifneq ($(filter SCRIPTING,$(BUILD_TYPE)),)
+
+$(eval $(call gb_Module_add_targets,scripting,\
+ $(if $(ENABLE_JAVA),\
+ Jar_HelloWorld \
+ Jar_Highlight \
+ Jar_MemoryUsage \
+ Jar_ScriptFramework \
+ $(if $(ENABLE_SCRIPTING_BEANSHELL),\
+ Jar_ScriptProviderForBeanShell \
+ Rdb_scriptproviderforbeanshell \
+ ) \
+ Jar_ScriptProviderForJava \
+ $(if $(ENABLE_SCRIPTING_JAVASCRIPT),\
+ Jar_ScriptProviderForJavaScript \
+ Rdb_scriptproviderforjavascript \
+ ) \
+ Package_java \
+ Package_java_jars \
+ $(if $(ENABLE_SCRIPTING_BEANSHELL),Package_ScriptsBeanShell) \
+ $(if $(ENABLE_SCRIPTING_JAVASCRIPT),Package_ScriptsJavaScript) \
+ ) \
+ $(if $(DISABLE_SCRIPTING),,Package_scriptbindinglib) \
+ $(if $(DISABLE_PYTHON),,\
+ Package_scriptproviderforpython \
+ Package_ScriptsPython \
+ Pyuno_mailmerge \
+ ) \
+ Library_basprov \
+ Library_dlgprov \
+ Library_protocolhandler \
+ Library_scriptframe \
+ Library_stringresource \
+ Library_vbaevents \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4: