summaryrefslogtreecommitdiffstats
path: root/stoc/Library_bootstrap.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /stoc/Library_bootstrap.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'stoc/Library_bootstrap.mk')
-rw-r--r--stoc/Library_bootstrap.mk52
1 files changed, 52 insertions, 0 deletions
diff --git a/stoc/Library_bootstrap.mk b/stoc/Library_bootstrap.mk
new file mode 100644
index 000000000..49fbafc12
--- /dev/null
+++ b/stoc/Library_bootstrap.mk
@@ -0,0 +1,52 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,bootstrap))
+
+ifneq ($(debug),)
+
+$(eval $(call gb_Library_add_defs,bootstrap,\
+ $(if $(diag),\
+ $(if $(filter $(diag),cache full),-D__CACHE_DIAGNOSE) \
+ $(if $(filter-out $(diag),cache),-D__DIAGNOSE)) \
+))
+
+endif
+
+$(eval $(call gb_Library_use_external,bootstrap,boost_headers))
+
+$(eval $(call gb_Library_use_internal_bootstrap_api,bootstrap,\
+ udkapi \
+))
+
+$(eval $(call gb_Library_use_libraries,bootstrap,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ reg \
+ sal \
+ salhelper \
+ tl \
+))
+
+$(eval $(call gb_Library_set_componentfile,bootstrap,stoc/util/bootstrap))
+
+$(eval $(call gb_Library_add_exception_objects,bootstrap,\
+ stoc/source/defaultregistry/defaultregistry \
+ stoc/source/implementationregistration/implreg \
+ stoc/source/implementationregistration/mergekeys \
+ stoc/source/loader/dllcomponentloader \
+ stoc/source/security/access_controller \
+ stoc/source/security/file_policy \
+ stoc/source/security/permissions \
+ stoc/source/servicemanager/servicemanager \
+ stoc/source/simpleregistry/simpleregistry \
+))
+
+# vim:set noet sw=4 ts=4: