summaryrefslogtreecommitdiffstats
path: root/sw/PythonTest_sw_python.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /sw/PythonTest_sw_python.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sw/PythonTest_sw_python.mk')
-rw-r--r--sw/PythonTest_sw_python.mk52
1 files changed, 52 insertions, 0 deletions
diff --git a/sw/PythonTest_sw_python.mk b/sw/PythonTest_sw_python.mk
new file mode 100644
index 000000000..d64a8b516
--- /dev/null
+++ b/sw/PythonTest_sw_python.mk
@@ -0,0 +1,52 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_PythonTest_PythonTest,sw_python))
+
+$(eval $(call gb_PythonTest_set_defs,sw_python,\
+ TDOC="$(SRCDIR)/sw/qa/python/testdocuments" \
+))
+
+$(eval $(call gb_PythonTest_add_modules,sw_python,$(SRCDIR)/sw/qa/python,\
+ check_bookmarks \
+ check_change_color \
+ check_drawpage \
+ check_index \
+ check_flies \
+ check_fields \
+ check_xcloseable \
+ check_cross_references \
+ check_named_property_values \
+ check_indexed_property_values \
+ check_range_properties \
+ check_styles \
+ check_table \
+ check_xautotextcontainer \
+ check_xautotextgroup \
+ check_xmodel \
+ check_xmodifiable2 \
+ check_xnamedgraph \
+ check_xrefreshable \
+ check_xtextrangecompare \
+ check_xtexttable \
+ get_expression \
+ set_expression \
+ text_portion_enumeration_test \
+ var_fields \
+ xscriptprovider \
+ xtextfieldssupplier \
+ xcontrolshape \
+ xstyleloader \
+ xtextcontent \
+ xtextrange \
+ xtext \
+ xtextcursor \
+))
+
+# vim: set noet sw=4 ts=4: