summaryrefslogtreecommitdiffstats
path: root/vcl/CustomTarget_qt5_moc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /vcl/CustomTarget_qt5_moc.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vcl/CustomTarget_qt5_moc.mk')
-rw-r--r--vcl/CustomTarget_qt5_moc.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/vcl/CustomTarget_qt5_moc.mk b/vcl/CustomTarget_qt5_moc.mk
new file mode 100644
index 000000000..87caee8d9
--- /dev/null
+++ b/vcl/CustomTarget_qt5_moc.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,vcl/qt5))
+
+$(call gb_CustomTarget_get_target,vcl/qt5) : \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5AccessibleWidget.moc \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5Clipboard.moc \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5FilePicker.moc \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5Frame.moc \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5Instance.moc \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5MainWindow.moc \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5Menu.moc \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5Object.moc \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5Timer.moc \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5Widget.moc \
+ $(call gb_CustomTarget_get_workdir,vcl/qt5)/Qt5XAccessible.moc \
+
+$(call gb_CustomTarget_get_workdir,vcl/qt5)/%.moc : \
+ $(SRCDIR)/vcl/inc/qt5/%.hxx \
+ | $(call gb_CustomTarget_get_workdir,vcl/qt5)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),MOC,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),MOC)
+ $(MOC5) $< -o $@
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),MOC)
+
+# vim: set noet sw=4: