summaryrefslogtreecommitdiffstats
path: root/debian/patches-rt/0175-locking-rtmutex-wire-up-RT-s-locking.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-08 17:45:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-08 17:45:36 +0000
commit429d3efd5669e129a6168d62edb6832e36b7a2a0 (patch)
tree14b99403f823ded018ba76aa450e8687247796b8 /debian/patches-rt/0175-locking-rtmutex-wire-up-RT-s-locking.patch
parentMerging upstream version 5.10.216. (diff)
downloadlinux-429d3efd5669e129a6168d62edb6832e36b7a2a0.tar.xz
linux-429d3efd5669e129a6168d62edb6832e36b7a2a0.zip
Adding debian version 5.10.216-1.debian/5.10.216-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches-rt/0175-locking-rtmutex-wire-up-RT-s-locking.patch')
-rw-r--r--debian/patches-rt/0175-locking-rtmutex-wire-up-RT-s-locking.patch28
1 files changed, 14 insertions, 14 deletions
diff --git a/debian/patches-rt/0175-locking-rtmutex-wire-up-RT-s-locking.patch b/debian/patches-rt/0175-locking-rtmutex-wire-up-RT-s-locking.patch
index 4a55d2f15..33267351f 100644
--- a/debian/patches-rt/0175-locking-rtmutex-wire-up-RT-s-locking.patch
+++ b/debian/patches-rt/0175-locking-rtmutex-wire-up-RT-s-locking.patch
@@ -1,8 +1,8 @@
-From 48720bc07f81cfe49fe8e2a7afa1f18acd9227dd Mon Sep 17 00:00:00 2001
+From 0e5272c5e589c6dcbccd3186136968479346695c Mon Sep 17 00:00:00 2001
From: Thomas Gleixner <tglx@linutronix.de>
Date: Thu, 12 Oct 2017 17:31:14 +0200
Subject: [PATCH 175/323] locking/rtmutex: wire up RT's locking
-Origin: https://www.kernel.org/pub/linux/kernel/projects/rt/5.10/older/patches-5.10.204-rt100.tar.xz
+Origin: https://www.kernel.org/pub/linux/kernel/projects/rt/5.10/older/patches-5.10.215-rt107.tar.xz
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
@@ -21,7 +21,7 @@ Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
11 files changed, 77 insertions(+), 19 deletions(-)
diff --git a/include/linux/mutex.h b/include/linux/mutex.h
-index 4d671fba3cab..e45774a337d2 100644
+index 4d671fba3cab4..e45774a337d2c 100644
--- a/include/linux/mutex.h
+++ b/include/linux/mutex.h
@@ -22,6 +22,20 @@
@@ -70,7 +70,7 @@ index 4d671fba3cab..e45774a337d2 100644
+
#endif /* __LINUX_MUTEX_H */
diff --git a/include/linux/rwsem.h b/include/linux/rwsem.h
-index 4c715be48717..9323af8a9244 100644
+index 4c715be487171..9323af8a92445 100644
--- a/include/linux/rwsem.h
+++ b/include/linux/rwsem.h
@@ -16,6 +16,11 @@
@@ -100,7 +100,7 @@ index 4c715be48717..9323af8a9244 100644
* lock for reading
*/
diff --git a/include/linux/spinlock.h b/include/linux/spinlock.h
-index 79897841a2cc..c3c70291b46c 100644
+index 79897841a2cc8..c3c70291b46c5 100644
--- a/include/linux/spinlock.h
+++ b/include/linux/spinlock.h
@@ -309,7 +309,11 @@ static inline void do_raw_spin_unlock(raw_spinlock_t *lock) __releases(lock)
@@ -137,7 +137,7 @@ index 79897841a2cc..c3c70291b46c 100644
* Pull the atomic_t declaration:
* (asm-mips/atomic.h needs above definitions)
diff --git a/include/linux/spinlock_api_smp.h b/include/linux/spinlock_api_smp.h
-index 19a9be9d97ee..da38149f2843 100644
+index 19a9be9d97ee5..da38149f28431 100644
--- a/include/linux/spinlock_api_smp.h
+++ b/include/linux/spinlock_api_smp.h
@@ -187,6 +187,8 @@ static inline int __raw_spin_trylock_bh(raw_spinlock_t *lock)
@@ -151,7 +151,7 @@ index 19a9be9d97ee..da38149f2843 100644
#endif /* __LINUX_SPINLOCK_API_SMP_H */
diff --git a/include/linux/spinlock_types.h b/include/linux/spinlock_types.h
-index 5c8664d57fb8..8d896d3e1a01 100644
+index 5c8664d57fb86..8d896d3e1a017 100644
--- a/include/linux/spinlock_types.h
+++ b/include/linux/spinlock_types.h
@@ -11,8 +11,13 @@
@@ -172,7 +172,7 @@ index 5c8664d57fb8..8d896d3e1a01 100644
#endif /* __LINUX_SPINLOCK_TYPES_H */
diff --git a/include/linux/spinlock_types_up.h b/include/linux/spinlock_types_up.h
-index c09b6407ae1b..d9b371fa13e0 100644
+index c09b6407ae1b3..d9b371fa13e09 100644
--- a/include/linux/spinlock_types_up.h
+++ b/include/linux/spinlock_types_up.h
@@ -1,7 +1,7 @@
@@ -185,7 +185,7 @@ index c09b6407ae1b..d9b371fa13e0 100644
#endif
diff --git a/kernel/Kconfig.preempt b/kernel/Kconfig.preempt
-index bf82259cff96..cbe3aa495519 100644
+index bf82259cff965..cbe3aa495519b 100644
--- a/kernel/Kconfig.preempt
+++ b/kernel/Kconfig.preempt
@@ -59,6 +59,7 @@ config PREEMPT_RT
@@ -197,7 +197,7 @@ index bf82259cff96..cbe3aa495519 100644
This option turns the kernel into a real-time kernel by replacing
various locking primitives (spinlocks, rwlocks, etc.) with
diff --git a/kernel/locking/Makefile b/kernel/locking/Makefile
-index 6d11cfb9b41f..c7fbf737e16e 100644
+index 6d11cfb9b41f2..c7fbf737e16ea 100644
--- a/kernel/locking/Makefile
+++ b/kernel/locking/Makefile
@@ -3,7 +3,7 @@
@@ -236,7 +236,7 @@ index 6d11cfb9b41f..c7fbf737e16e 100644
obj-$(CONFIG_LOCK_TORTURE_TEST) += locktorture.o
obj-$(CONFIG_WW_MUTEX_SELFTEST) += test-ww_mutex.o
diff --git a/kernel/locking/rwsem.c b/kernel/locking/rwsem.c
-index cc5cc889b5b7..f7c909ef1261 100644
+index cc5cc889b5b7f..f7c909ef1261d 100644
--- a/kernel/locking/rwsem.c
+++ b/kernel/locking/rwsem.c
@@ -28,6 +28,7 @@
@@ -276,7 +276,7 @@ index cc5cc889b5b7..f7c909ef1261 100644
}
EXPORT_SYMBOL(up_read_non_owner);
diff --git a/kernel/locking/spinlock.c b/kernel/locking/spinlock.c
-index 0ff08380f531..45445a2f1799 100644
+index 0ff08380f5318..45445a2f1799a 100644
--- a/kernel/locking/spinlock.c
+++ b/kernel/locking/spinlock.c
@@ -124,8 +124,11 @@ void __lockfunc __raw_##op##_lock_bh(locktype##_t *lock) \
@@ -310,7 +310,7 @@ index 0ff08380f531..45445a2f1799 100644
void __lockfunc _raw_spin_lock_nested(raw_spinlock_t *lock, int subclass)
diff --git a/kernel/locking/spinlock_debug.c b/kernel/locking/spinlock_debug.c
-index b9d93087ee66..72e306e0e8a3 100644
+index b9d93087ee669..72e306e0e8a3b 100644
--- a/kernel/locking/spinlock_debug.c
+++ b/kernel/locking/spinlock_debug.c
@@ -31,6 +31,7 @@ void __raw_spin_lock_init(raw_spinlock_t *lock, const char *name,
@@ -344,5 +344,5 @@ index b9d93087ee66..72e306e0e8a3 100644
+
+#endif
--
-2.43.0
+2.44.0