summaryrefslogtreecommitdiffstats
path: root/net/tls/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 10:05:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 10:05:51 +0000
commit5d1646d90e1f2cceb9f0828f4b28318cd0ec7744 (patch)
treea94efe259b9009378be6d90eb30d2b019d95c194 /net/tls/Makefile
parentInitial commit. (diff)
downloadlinux-5d1646d90e1f2cceb9f0828f4b28318cd0ec7744.tar.xz
linux-5d1646d90e1f2cceb9f0828f4b28318cd0ec7744.zip
Adding upstream version 5.10.209.upstream/5.10.209
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'net/tls/Makefile')
-rw-r--r--net/tls/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/net/tls/Makefile b/net/tls/Makefile
new file mode 100644
index 000000000..f1ffbfe89
--- /dev/null
+++ b/net/tls/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the TLS subsystem.
+#
+
+CFLAGS_trace.o := -I$(src)
+
+obj-$(CONFIG_TLS) += tls.o
+
+tls-y := tls_main.o tls_sw.o tls_proc.o trace.o
+
+tls-$(CONFIG_TLS_TOE) += tls_toe.o
+tls-$(CONFIG_TLS_DEVICE) += tls_device.o tls_device_fallback.o