summaryrefslogtreecommitdiffstats
path: root/test/TEST-13-NSPAWN-SMOKE
diff options
context:
space:
mode:
Diffstat (limited to '')
l---------test/TEST-13-NSPAWN-SMOKE/Makefile1
-rwxr-xr-xtest/TEST-13-NSPAWN-SMOKE/test.sh23
2 files changed, 24 insertions, 0 deletions
diff --git a/test/TEST-13-NSPAWN-SMOKE/Makefile b/test/TEST-13-NSPAWN-SMOKE/Makefile
new file mode 120000
index 0000000..e9f93b1
--- /dev/null
+++ b/test/TEST-13-NSPAWN-SMOKE/Makefile
@@ -0,0 +1 @@
+../TEST-01-BASIC/Makefile \ No newline at end of file
diff --git a/test/TEST-13-NSPAWN-SMOKE/test.sh b/test/TEST-13-NSPAWN-SMOKE/test.sh
new file mode 100755
index 0000000..236378a
--- /dev/null
+++ b/test/TEST-13-NSPAWN-SMOKE/test.sh
@@ -0,0 +1,23 @@
+#!/usr/bin/env bash
+set -e
+TEST_DESCRIPTION="systemd-nspawn smoke test"
+IMAGE_NAME="nspawn"
+TEST_NO_NSPAWN=1
+
+. $TEST_BASE_DIR/test-functions
+
+test_create_image() {
+ create_empty_image_rootdir
+
+ # Create what will eventually be our root filesystem onto an overlay
+ (
+ LOG_LEVEL=5
+ setup_basic_environment
+ mask_supporting_services
+
+ ../create-busybox-container $initdir/testsuite-13.nc-container
+ initdir="$initdir/testsuite-13.nc-container" dracut_install nc ip md5sum
+ )
+}
+
+do_test "$@" 13