summaryrefslogtreecommitdiffstats
path: root/os/config.m4
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 06:33:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 06:33:50 +0000
commitfe39ffb8b90ae4e002ed73fe98617cd590abb467 (patch)
treeb80e5956907d8aeaaffe4e4f0c068c0e6157ce8b /os/config.m4
parentInitial commit. (diff)
downloadapache2-upstream.tar.xz
apache2-upstream.zip
Adding upstream version 2.4.56.upstream/2.4.56upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--os/config.m426
1 files changed, 26 insertions, 0 deletions
diff --git a/os/config.m4 b/os/config.m4
new file mode 100644
index 0000000..3188091
--- /dev/null
+++ b/os/config.m4
@@ -0,0 +1,26 @@
+AC_MSG_CHECKING(for target platform)
+
+case $host in
+*pc-os2-emx*)
+ OS="os2"
+ OS_DIR=$OS
+ ;;
+bs2000*)
+ OS="unix"
+ OS_DIR=$OS
+ ;;
+*cygwin*)
+ OS="cygwin"
+ OS_DIR="unix"
+ ;;
+*mingw32*)
+ OS="win32"
+ OS_DIR=$OS
+ ;;
+*)
+ OS="unix"
+ OS_DIR=$OS;;
+esac
+
+AC_MSG_RESULT($OS)
+APACHE_FAST_OUTPUT(os/${OS_DIR}/Makefile)