summaryrefslogtreecommitdiffstats
path: root/bin/plugins/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--bin/plugins/Makefile.in67
1 files changed, 67 insertions, 0 deletions
diff --git a/bin/plugins/Makefile.in b/bin/plugins/Makefile.in
new file mode 100644
index 0000000..4bd606a
--- /dev/null
+++ b/bin/plugins/Makefile.in
@@ -0,0 +1,67 @@
+# Copyright (C) Internet Systems Consortium, Inc. ("ISC")
+#
+# SPDX-License-Identifier: MPL-2.0
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, you can obtain one at https://mozilla.org/MPL/2.0/.
+#
+# See the COPYRIGHT file distributed with this work for additional
+# information regarding copyright ownership.
+
+srcdir = @srcdir@
+VPATH = @srcdir@
+top_srcdir = @top_srcdir@
+
+@BIND9_MAKE_INCLUDES@
+
+CINCLUDES = -I${srcdir}/include -I${srcdir}/unix/include -I. \
+ ${NS_INCLUDES} ${DNS_INCLUDES} \
+ ${ISCCFG_INCLUDES} ${ISC_INCLUDES}
+
+DNSLIBS = ../../lib/dns/libdns.@A@ @NO_LIBTOOL_DNSLIBS@
+ISCCFGLIBS = ../../lib/isccfg/libisccfg.@A@
+ISCLIBS = ../../lib/isc/libisc.@A@ @NO_LIBTOOL_ISCLIBS@
+NSLIBS = ../../lib/ns/libns.@A@
+
+LIBS =
+
+SO_TARGETS = lib/filter-aaaa.@SO@
+SO_INSTALL = filter-aaaa.@SO@
+TARGETS = @SO_TARGETS@
+
+SO_OBJS = filter-aaaa.@O@
+SO_SRCS = filter-aaaa.c
+
+CFLAGS = @CFLAGS@ @SO_CFLAGS@
+SO_LDFLAGS = @LDFLAGS@ @SO_LDFLAGS@
+
+@BIND9_MAKE_RULES@
+
+lib/filter-aaaa.@SO@: filter-aaaa.@SO@
+ $(SHELL) ${top_srcdir}/mkinstalldirs `pwd`/lib
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL} filter-aaaa.@SO@ `pwd`/lib
+
+filter-aaaa.@SO@: filter-aaaa.@O@
+ ${LIBTOOL_MODE_LINK} @SO_LD@ ${SO_LDFLAGS} -o $@ \
+ filter-aaaa.@O@ ${LIBS}
+
+clean distclean::
+ rm -f filter-aaaa.so
+ rm -f ${TARGETS} ${OBJS}
+
+installdirs:
+ $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${plugindir}
+
+install:: @SO_TARGETS@ installdirs
+ for i in ${SO_INSTALL} ; \
+ do \
+ if test -f $$i ; \
+ then \
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_LIBRARY} $$i \
+ ${DESTDIR}${plugindir}; \
+ fi \
+ done
+
+uninstall::
+ ${LIBTOOL_MODE_UNINSTALL} rm -f ${DESTDIR}${plugindir}/filter-aaaa.@SO@