summaryrefslogtreecommitdiffstats
path: root/debian/patches/riscv64-link-pthread.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:29 +0000
commitdf4528d6668ab18e40584fe540355bdfba0fb6dd (patch)
treef1bfdcb6485edff853369405dd5423c662c47345 /debian/patches/riscv64-link-pthread.patch
parentAdding upstream version 14.2.21. (diff)
downloadceph-df4528d6668ab18e40584fe540355bdfba0fb6dd.tar.xz
ceph-df4528d6668ab18e40584fe540355bdfba0fb6dd.zip
Adding debian version 14.2.21-1.debian/14.2.21-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--debian/patches/riscv64-link-pthread.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/patches/riscv64-link-pthread.patch b/debian/patches/riscv64-link-pthread.patch
new file mode 100644
index 00000000..5d4a72d4
--- /dev/null
+++ b/debian/patches/riscv64-link-pthread.patch
@@ -0,0 +1,16 @@
+Description: Link with -pthread instead of -lpthread to fix FTBFS on riscv64
+Forwarded: no
+Last-Update: 2020-03-01
+
+Index: ceph/CMakeLists.txt
+===================================================================
+--- ceph.orig/CMakeLists.txt
++++ ceph/CMakeLists.txt
+@@ -31,6 +31,7 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_S
+
+ if(CMAKE_SYSTEM_NAME MATCHES "Linux")
+ set(LINUX ON)
++ set(THREADS_PREFER_PTHREAD_FLAG ON)
+ FIND_PACKAGE(Threads)
+ elseif(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+ set(FREEBSD ON)