summaryrefslogtreecommitdiffstats
path: root/etc/sysctl/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /etc/sysctl/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--etc/sysctl/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/etc/sysctl/CMakeLists.txt b/etc/sysctl/CMakeLists.txt
new file mode 100644
index 00000000..682541b0
--- /dev/null
+++ b/etc/sysctl/CMakeLists.txt
@@ -0,0 +1,9 @@
+if(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ # 4194304 is the maximum limit possible on 64-bit CONFIG_BASE_FULL kernels.
+ # Keep the default for 32-bit systems.
+ set(sysctl_pid_max "kernel.pid_max = 4194304")
+endif()
+
+configure_file(90-ceph-osd.conf.in
+ ${CMAKE_CURRENT_SOURCE_DIR}/90-ceph-osd.conf
+ @ONLY)