summaryrefslogtreecommitdiffstats
path: root/etc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /etc
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'etc')
-rw-r--r--etc/default/ceph7
-rw-r--r--etc/sysconfig/ceph18
-rw-r--r--etc/sysctl/.gitignore1
-rw-r--r--etc/sysctl/90-ceph-osd.conf.in2
-rw-r--r--etc/sysctl/CMakeLists.txt9
5 files changed, 37 insertions, 0 deletions
diff --git a/etc/default/ceph b/etc/default/ceph
new file mode 100644
index 00000000..4542838f
--- /dev/null
+++ b/etc/default/ceph
@@ -0,0 +1,7 @@
+# /etc/default/ceph
+#
+# Environment file for ceph daemon systemd unit files.
+#
+
+# Increase tcmalloc cache size
+TCMALLOC_MAX_TOTAL_THREAD_CACHE_BYTES=134217728
diff --git a/etc/sysconfig/ceph b/etc/sysconfig/ceph
new file mode 100644
index 00000000..c7f4bc45
--- /dev/null
+++ b/etc/sysconfig/ceph
@@ -0,0 +1,18 @@
+# /etc/sysconfig/ceph
+#
+# Environment file for ceph daemon systemd unit files.
+#
+
+# Increase tcmalloc cache size
+TCMALLOC_MAX_TOTAL_THREAD_CACHE_BYTES=134217728
+
+## automatically restart systemd units on upgrade
+#
+# By default, it is left to the administrator to restart
+# ceph daemons (or their related systemd units) manually
+# when the 'ceph' package is upgraded. By setting this
+# parameter to "yes", package upgrade will trigger a
+# "systemctl try-restart" on all the ceph systemd units
+# currently active on the node.
+#
+CEPH_AUTO_RESTART_ON_UPGRADE=no
diff --git a/etc/sysctl/.gitignore b/etc/sysctl/.gitignore
new file mode 100644
index 00000000..5529d37d
--- /dev/null
+++ b/etc/sysctl/.gitignore
@@ -0,0 +1 @@
+90-ceph-osd.conf
diff --git a/etc/sysctl/90-ceph-osd.conf.in b/etc/sysctl/90-ceph-osd.conf.in
new file mode 100644
index 00000000..96bd40ac
--- /dev/null
+++ b/etc/sysctl/90-ceph-osd.conf.in
@@ -0,0 +1,2 @@
+fs.aio-max-nr = 1048576
+@sysctl_pid_max@
diff --git a/etc/sysctl/CMakeLists.txt b/etc/sysctl/CMakeLists.txt
new file mode 100644
index 00000000..682541b0
--- /dev/null
+++ b/etc/sysctl/CMakeLists.txt
@@ -0,0 +1,9 @@
+if(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ # 4194304 is the maximum limit possible on 64-bit CONFIG_BASE_FULL kernels.
+ # Keep the default for 32-bit systems.
+ set(sysctl_pid_max "kernel.pid_max = 4194304")
+endif()
+
+configure_file(90-ceph-osd.conf.in
+ ${CMAKE_CURRENT_SOURCE_DIR}/90-ceph-osd.conf
+ @ONLY)