summaryrefslogtreecommitdiffstats
path: root/make-srpm.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /make-srpm.sh
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'make-srpm.sh')
-rwxr-xr-xmake-srpm.sh11
1 files changed, 11 insertions, 0 deletions
diff --git a/make-srpm.sh b/make-srpm.sh
new file mode 100755
index 00000000..1ba0ff08
--- /dev/null
+++ b/make-srpm.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+#
+# Create a SRPM which can be used to build Ceph
+#
+# ./make-srpm.sh <version>
+# rpmbuild --rebuild /tmp/ceph/ceph-<version>-0.el7.centos.src.rpm
+#
+
+./make-dist $1
+rpmbuild -D"_sourcedir `pwd`" -D"_specdir `pwd`" -D"_srcrpmdir `pwd`" -bs ceph.spec