summaryrefslogtreecommitdiffstats
path: root/selinux/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /selinux/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'selinux/CMakeLists.txt')
-rw-r--r--selinux/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/selinux/CMakeLists.txt b/selinux/CMakeLists.txt
new file mode 100644
index 00000000..d0a7e54f
--- /dev/null
+++ b/selinux/CMakeLists.txt
@@ -0,0 +1,11 @@
+add_custom_target(
+ ceph.pp ALL
+ COMMAND ln -sf ${CMAKE_CURRENT_SOURCE_DIR}/ceph.* .
+ COMMAND make -f ${SELINUX_MAKEFILE} ceph.pp
+ DEPENDS ceph.te ceph.fc ceph.if)
+
+set(datadir ${CMAKE_INSTALL_PREFIX}/share/selinux)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ceph.pp
+ DESTINATION ${datadir}/packages)
+install(FILES ceph.if
+ DESTINATION ${datadir}/devel/include/contrib)