summaryrefslogtreecommitdiffstats
path: root/src/auth/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/auth/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/auth/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/auth/CMakeLists.txt b/src/auth/CMakeLists.txt
new file mode 100644
index 00000000..d4bfa1a5
--- /dev/null
+++ b/src/auth/CMakeLists.txt
@@ -0,0 +1,31 @@
+set(auth_srcs
+ AuthClientHandler.cc
+ AuthMethodList.cc
+ AuthRegistry.cc
+ AuthSessionHandler.cc
+ Crypto.cc
+ KeyRing.cc
+ RotatingKeyRing.cc
+ cephx/CephxAuthorizeHandler.cc
+ cephx/CephxClientHandler.cc
+ cephx/CephxProtocol.cc
+ cephx/CephxSessionHandler.cc
+ none/AuthNoneAuthorizeHandler.cc
+ unknown/AuthUnknownAuthorizeHandler.cc)
+
+if(HAVE_GSSAPI)
+ list(APPEND auth_srcs
+ krb/KrbAuthorizeHandler.cpp
+ krb/KrbClientHandler.cpp
+ krb/KrbProtocol.cpp
+ krb/KrbSessionHandler.hpp)
+endif()
+
+add_library(common-auth-objs OBJECT ${auth_srcs})
+if(WITH_SEASTAR)
+ add_library(crimson-auth OBJECT ${auth_srcs})
+ target_compile_definitions(crimson-auth PRIVATE
+ "WITH_SEASTAR=1")
+ target_include_directories(crimson-auth PRIVATE
+ $<TARGET_PROPERTY:Seastar::seastar,INTERFACE_INCLUDE_DIRECTORIES>)
+endif()