summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/hana/test/deploy
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/boost/libs/hana/test/deploy
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/hana/test/deploy')
-rw-r--r--src/boost/libs/hana/test/deploy/CMakeLists.txt10
-rw-r--r--src/boost/libs/hana/test/deploy/main.cpp8
2 files changed, 18 insertions, 0 deletions
diff --git a/src/boost/libs/hana/test/deploy/CMakeLists.txt b/src/boost/libs/hana/test/deploy/CMakeLists.txt
new file mode 100644
index 00000000..186d5def
--- /dev/null
+++ b/src/boost/libs/hana/test/deploy/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Copyright Louis Dionne 2013-2017
+# Distributed under the Boost Software License, Version 1.0.
+# (See accompanying file LICENSE.md or copy at http://boost.org/LICENSE_1_0.txt)
+
+cmake_minimum_required(VERSION 3.0)
+project(external CXX)
+find_package(Hana REQUIRED)
+
+add_executable(main main.cpp)
+target_link_libraries(main hana)
diff --git a/src/boost/libs/hana/test/deploy/main.cpp b/src/boost/libs/hana/test/deploy/main.cpp
new file mode 100644
index 00000000..e35e8135
--- /dev/null
+++ b/src/boost/libs/hana/test/deploy/main.cpp
@@ -0,0 +1,8 @@
+// Copyright Louis Dionne 2013-2017
+// Distributed under the Boost Software License, Version 1.0.
+// (See accompanying file LICENSE.md or copy at http://boost.org/LICENSE_1_0.txt)
+
+#include <boost/hana.hpp>
+
+
+int main() { }