summaryrefslogtreecommitdiffstats
path: root/src/civetweb/distribution
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/civetweb/distribution
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/civetweb/distribution')
-rw-r--r--src/civetweb/distribution/arch/PKGBUILD.git.example42
-rw-r--r--src/civetweb/distribution/arch/civetweb.service9
2 files changed, 51 insertions, 0 deletions
diff --git a/src/civetweb/distribution/arch/PKGBUILD.git.example b/src/civetweb/distribution/arch/PKGBUILD.git.example
new file mode 100644
index 00000000..7102bcb3
--- /dev/null
+++ b/src/civetweb/distribution/arch/PKGBUILD.git.example
@@ -0,0 +1,42 @@
+# An example PKGBUILD script for Civetweb upstream, git version
+# Rename to PKGBUILD to build via makepkg
+_pkgname=civetweb
+pkgname=$_pkgname-git
+pkgver=v1.4.24.g73c40b6
+pkgrel=1
+pkgdesc="Small and quick-to-use web server; https/php/cgi support; MIT license - git development version"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/p/civetweb/"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('git sed')
+optdepends=('php-cgi: for php support')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+backup=("etc/$_pkgname/$_pkgname.conf")
+source=("$_pkgname::git+https://github.com/civetweb/civetweb.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make build WITH_IPV6=1
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make install PREFIX="$pkgdir/usr" SYSCONFDIR="$pkgdir/etc/local/$_pkgname"
+
+ install -Dm644 "$srcdir/$_pkgname/distribution/arch/$_pkgname.service" "$pkgdir/usr/lib/systemd/system/$_pkgname.service"
+
+ sed -i "s/^document_root [^\n]*/document_root \/srv\/http/g" "$pkgdir/etc/local/$_pkgname/$_pkgname.conf"
+ sed -i "s/^# access_log_file/access_log_file \/var\/log\/$_pkgname\/access.log/g" "$pkgdir/etc/local/$_pkgname/$_pkgname.conf"
+ sed -i "s/^# error_log_file/access_log_file \/var\/log\/$_pkgname\/error.log/g" "$pkgdir/etc/local/$_pkgname/$_pkgname.conf"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/src/civetweb/distribution/arch/civetweb.service b/src/civetweb/distribution/arch/civetweb.service
new file mode 100644
index 00000000..5327b6ca
--- /dev/null
+++ b/src/civetweb/distribution/arch/civetweb.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Civetweb httpd
+After=syslog.target network.target remote-fs.target nss-lookup.target
+
+[Service]
+ExecStart=/usr/local/bin/civetweb /usr/local/etc/civetweb/civetweb.conf
+
+[Install]
+WantedBy=multi-user.target