summaryrefslogtreecommitdiffstats
path: root/src/civetweb/resources/Makefile.in-os
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/civetweb/resources/Makefile.in-os
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/civetweb/resources/Makefile.in-os')
-rw-r--r--src/civetweb/resources/Makefile.in-os23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/civetweb/resources/Makefile.in-os b/src/civetweb/resources/Makefile.in-os
new file mode 100644
index 00000000..a7591348
--- /dev/null
+++ b/src/civetweb/resources/Makefile.in-os
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2013 No Face Press, LLC
+# License http://opensource.org/licenses/mit-license.php MIT License
+#
+
+# Override this using TARGET_OS=LINUX on the command line
+ifeq ($(TARGET_OS),)
+ ifeq ($(OS),Windows_NT)
+ TARGET_OS = WIN32
+ else
+ UNAME_S := $(shell uname -s)
+ ifeq ($(UNAME_S),Linux)
+ TARGET_OS = LINUX
+ else
+ ifeq ($(UNAME_S),Darwin)
+ TARGET_OS = OSX
+ else
+ TARGET_OS = BSD
+ endif
+ endif
+ endif
+endif
+