summaryrefslogtreecommitdiffstats
path: root/src/civetweb/test/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/civetweb/test/README.md
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/civetweb/test/README.md')
-rw-r--r--src/civetweb/test/README.md25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/civetweb/test/README.md b/src/civetweb/test/README.md
new file mode 100644
index 00000000..49f2245d
--- /dev/null
+++ b/src/civetweb/test/README.md
@@ -0,0 +1,25 @@
+Testing
+=======
+
+C API
+-----
+
+The unit tests leverage the CTest and Check frameworks to provide a easy
+environment to build up unit tests. They are split into Public and Private
+test suites reflecting the public and internal API functions of civetweb.
+
+When adding new functionality to civetweb tests should be written so that the
+new functionality will be tested across the continuous build servers. There
+are various levels of the unit tests:
+
+ * Tests are included in
+ * Test Cases which are there are multiple in
+ * Test Suites which are ran by the check framework by
+ * `civetweb-unit-tests` which is driven using the `--suite` and
+ `--test-case` arguments by
+ * CTest via `add_test` in `CMakeLists.txt`
+
+Each test suite and test case is ran individually by CTest so that it provides
+good feedback to the continuous integration servers and also CMake. Adding a
+new test case or suite will require the corresponding `add_test` driver to be
+added to `CMakeLists.txt`