summaryrefslogtreecommitdiffstats
path: root/src/erasure-code/lrc/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/erasure-code/lrc/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/erasure-code/lrc/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/erasure-code/lrc/CMakeLists.txt b/src/erasure-code/lrc/CMakeLists.txt
new file mode 100644
index 00000000..e7fb8ea0
--- /dev/null
+++ b/src/erasure-code/lrc/CMakeLists.txt
@@ -0,0 +1,15 @@
+# lrc plugin
+
+set(lrc_srcs
+ ErasureCodePluginLrc.cc
+ ErasureCodeLrc.cc
+ $<TARGET_OBJECTS:erasure_code_objs>
+ $<TARGET_OBJECTS:crush_objs>
+ ${CMAKE_SOURCE_DIR}/src/common/str_map.cc
+)
+
+add_library(ec_lrc SHARED ${lrc_srcs})
+set_target_properties(ec_lrc PROPERTIES
+ INSTALL_RPATH "")
+target_link_libraries(ec_lrc json_spirit)
+install(TARGETS ec_lrc DESTINATION ${erasure_plugin_dir})