summaryrefslogtreecommitdiffstats
path: root/src/erasure-code/shec/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/erasure-code/shec/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/erasure-code/shec/CMakeLists.txt')
-rw-r--r--src/erasure-code/shec/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/erasure-code/shec/CMakeLists.txt b/src/erasure-code/shec/CMakeLists.txt
new file mode 100644
index 00000000..0e699203
--- /dev/null
+++ b/src/erasure-code/shec/CMakeLists.txt
@@ -0,0 +1,33 @@
+#shec plugin
+
+include_directories(.)
+
+set(shec_utils_srcs
+ ${CMAKE_SOURCE_DIR}/src/erasure-code/ErasureCode.cc
+ ErasureCodePluginShec.cc
+ ErasureCodeShec.cc
+ ErasureCodeShecTableCache.cc
+ determinant.c)
+
+add_library(shec_utils OBJECT ${shec_utils_srcs})
+
+set(ec_shec_objs
+ $<TARGET_OBJECTS:gf-complete_objs>
+ $<TARGET_OBJECTS:jerasure_objs>
+ $<TARGET_OBJECTS:shec_utils>)
+
+add_library(ec_shec SHARED ${ec_shec_objs})
+set_target_properties(ec_shec PROPERTIES
+ INSTALL_RPATH "")
+target_link_libraries(ec_shec ${EXTRALIBS})
+install(TARGETS ec_shec DESTINATION ${erasure_plugin_dir})
+
+# legacy libraries
+foreach(flavor ${jerasure_legacy_flavors})
+ set(plugin_name "ec_shec_${flavor}")
+ add_library(${plugin_name} SHARED ${ec_shec_objs})
+ set_target_properties(${plugin_name} PROPERTIES
+ INSTALL_RPATH "")
+ install(TARGETS ${plugin_name} DESTINATION ${erasure_plugin_dir})
+ add_dependencies(ec_shec ${plugin_name})
+endforeach()