summaryrefslogtreecommitdiffstats
path: root/src/osdc/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/osdc/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/osdc/CMakeLists.txt')
-rw-r--r--src/osdc/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/osdc/CMakeLists.txt b/src/osdc/CMakeLists.txt
new file mode 100644
index 00000000..ef34e629
--- /dev/null
+++ b/src/osdc/CMakeLists.txt
@@ -0,0 +1,9 @@
+set(osdc_files
+ Filer.cc
+ ObjectCacher.cc
+ Objecter.cc
+ Striper.cc)
+add_library(osdc STATIC ${osdc_files})
+if(WITH_LTTNG AND WITH_EVENTTRACE)
+ add_dependencies(osdc eventtrace_tp)
+endif()