summaryrefslogtreecommitdiffstats
path: root/src/spdk/test/env/vtophys
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/spdk/test/env/vtophys
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/test/env/vtophys')
-rw-r--r--src/spdk/test/env/vtophys/.gitignore1
-rw-r--r--src/spdk/test/env/vtophys/Makefile42
-rw-r--r--src/spdk/test/env/vtophys/vtophys.c135
3 files changed, 178 insertions, 0 deletions
diff --git a/src/spdk/test/env/vtophys/.gitignore b/src/spdk/test/env/vtophys/.gitignore
new file mode 100644
index 00000000..a03b46cc
--- /dev/null
+++ b/src/spdk/test/env/vtophys/.gitignore
@@ -0,0 +1 @@
+vtophys
diff --git a/src/spdk/test/env/vtophys/Makefile b/src/spdk/test/env/vtophys/Makefile
new file mode 100644
index 00000000..7dc4d005
--- /dev/null
+++ b/src/spdk/test/env/vtophys/Makefile
@@ -0,0 +1,42 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../../..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.app.mk
+
+LIBS += $(ENV_LINKER_ARGS)
+TEST_FILE = vtophys.c
+
+ADDITIONAL_LIBS += $(ENV_LIBS)
+include $(SPDK_ROOT_DIR)/mk/spdk.unittest.mk
diff --git a/src/spdk/test/env/vtophys/vtophys.c b/src/spdk/test/env/vtophys/vtophys.c
new file mode 100644
index 00000000..d672b1ae
--- /dev/null
+++ b/src/spdk/test/env/vtophys/vtophys.c
@@ -0,0 +1,135 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include "spdk/stdinc.h"
+
+#include "spdk/env.h"
+
+static int
+vtophys_negative_test(void)
+{
+ void *p = NULL;
+ int i;
+ unsigned int size = 1;
+ int rc = 0;
+
+ for (i = 0; i < 31; i++) {
+ p = malloc(size);
+ if (p == NULL) {
+ continue;
+ }
+
+ if (spdk_vtophys(p) != SPDK_VTOPHYS_ERROR) {
+ rc = -1;
+ printf("Err: VA=%p is mapped to a huge_page,\n", p);
+ free(p);
+ break;
+ }
+
+ free(p);
+ size = size << 1;
+ }
+
+ /* Test addresses that are not in the valid x86-64 usermode range */
+
+ if (spdk_vtophys((void *)0x0000800000000000ULL) != SPDK_VTOPHYS_ERROR) {
+ rc = -1;
+ printf("Err: kernel-mode address incorrectly allowed\n");
+ }
+
+ if (!rc) {
+ printf("vtophys_negative_test passed\n");
+ } else {
+ printf("vtophys_negative_test failed\n");
+ }
+
+ return rc;
+}
+
+static int
+vtophys_positive_test(void)
+{
+ void *p = NULL;
+ int i;
+ unsigned int size = 1;
+ int rc = 0;
+
+ for (i = 0; i < 31; i++) {
+ p = spdk_dma_zmalloc(size, 512, NULL);
+ if (p == NULL) {
+ continue;
+ }
+
+ if (spdk_vtophys(p) == SPDK_VTOPHYS_ERROR) {
+ rc = -1;
+ printf("Err: VA=%p is not mapped to a huge_page,\n", p);
+ spdk_dma_free(p);
+ break;
+ }
+
+ spdk_dma_free(p);
+ size = size << 1;
+ }
+
+ if (!rc) {
+ printf("vtophys_positive_test passed\n");
+ } else {
+ printf("vtophys_positive_test failed\n");
+ }
+
+ return rc;
+}
+
+int
+main(int argc, char **argv)
+{
+ int rc;
+ struct spdk_env_opts opts;
+
+ spdk_env_opts_init(&opts);
+ opts.name = "vtophys";
+ opts.core_mask = "0x1";
+ opts.mem_size = 256;
+ if (spdk_env_init(&opts) < 0) {
+ printf("Err: Unable to initialize SPDK env\n");
+ return 1;
+ }
+
+ rc = vtophys_negative_test();
+ if (rc < 0) {
+ return rc;
+ }
+
+ rc = vtophys_positive_test();
+ return rc;
+}