summaryrefslogtreecommitdiffstats
path: root/src/test/ObjectMap/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/test/ObjectMap/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/ObjectMap/CMakeLists.txt')
-rw-r--r--src/test/ObjectMap/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/test/ObjectMap/CMakeLists.txt b/src/test/ObjectMap/CMakeLists.txt
new file mode 100644
index 00000000..837ec543
--- /dev/null
+++ b/src/test/ObjectMap/CMakeLists.txt
@@ -0,0 +1,42 @@
+# ceph_test_object_map
+add_executable(ceph_test_object_map
+ test_object_map.cc
+ KeyValueDBMemory.cc
+ )
+add_ceph_unittest(ceph_test_object_map)
+target_link_libraries(ceph_test_object_map
+ os
+ ceph-common
+ ${UNITTEST_LIBS}
+ global
+ ${EXTRALIBS}
+ ${CMAKE_DL_LIBS}
+ )
+
+# ceph_test_keyvaluedb_atomicity
+add_executable(ceph_test_keyvaluedb_atomicity
+ test_keyvaluedb_atomicity.cc
+ )
+target_link_libraries(ceph_test_keyvaluedb_atomicity
+ os
+ ceph-common
+ ${UNITTEST_LIBS}
+ global
+ ${EXTRALIBS}
+ ${CMAKE_DL_LIBS}
+ )
+
+# ceph_test_keyvaluedb_iterators
+add_executable(ceph_test_keyvaluedb_iterators
+ test_keyvaluedb_iterators.cc
+ KeyValueDBMemory.cc
+ )
+target_link_libraries(ceph_test_keyvaluedb_iterators
+ os
+ ceph-common
+ ${UNITTEST_LIBS}
+ global
+ ${EXTRALIBS}
+ ${CMAKE_DL_LIBS}
+ )
+