summaryrefslogtreecommitdiffstats
path: root/src/test/alpine-edge/Dockerfile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/test/alpine-edge/Dockerfile.in
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/alpine-edge/Dockerfile.in')
-rw-r--r--src/test/alpine-edge/Dockerfile.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/test/alpine-edge/Dockerfile.in b/src/test/alpine-edge/Dockerfile.in
new file mode 100644
index 00000000..2ffed1c1
--- /dev/null
+++ b/src/test/alpine-edge/Dockerfile.in
@@ -0,0 +1,8 @@
+FROM alpine:%%os_version%%
+COPY install-deps.sh /root/
+COPY APKBUILD.in /root/alpine/APKBUILD.in
+RUN apk --update --no-cache add bash sudo
+RUN if test %%USER%% != root ; then adduser -D -H -u %%user_id%% %%USER%% && echo '%%USER%% ALL=(ALL) NOPASSWD:ALL' >> /etc/sudoers ; fi
+# build dependencies
+RUN cd /root ; ./install-deps.sh
+