summaryrefslogtreecommitdiffstats
path: root/src/test/python/brag-client/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/test/python/brag-client/setup.py
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/test/python/brag-client/setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/test/python/brag-client/setup.py b/src/test/python/brag-client/setup.py
new file mode 100644
index 00000000..7f2bc7a2
--- /dev/null
+++ b/src/test/python/brag-client/setup.py
@@ -0,0 +1,31 @@
+import os
+from setuptools import setup, find_packages
+
+# link ceph-brag client script here so we can "install" it
+current_dir = os.path.abspath(os.path.dirname(__file__))
+src_dir = os.path.dirname(os.path.dirname(os.path.dirname(current_dir)))
+script_path = os.path.join(src_dir, 'brag/client/ceph-brag')
+
+
+def link_target(source, destination):
+ if not os.path.exists(destination):
+ try:
+ os.symlink(source, destination)
+ except (IOError, OSError) as error:
+ print('Ignoring linking of target: %s' % str(error))
+
+link_target(script_path, 'ceph_brag.py')
+
+setup(
+ name='ceph_brag',
+ version='0.1',
+ description='',
+ author='',
+ author_email='',
+ install_requires=[
+ "requests",
+ ],
+ zip_safe=False,
+ packages=find_packages(),
+ #packages=find_packages(exclude=['ez_setup'])
+)