summaryrefslogtreecommitdiffstats
path: root/src/xxHash/cmake_unofficial
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/xxHash/cmake_unofficial
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/xxHash/cmake_unofficial')
-rw-r--r--src/xxHash/cmake_unofficial/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/xxHash/cmake_unofficial/CMakeLists.txt b/src/xxHash/cmake_unofficial/CMakeLists.txt
new file mode 100644
index 00000000..825193e1
--- /dev/null
+++ b/src/xxHash/cmake_unofficial/CMakeLists.txt
@@ -0,0 +1,24 @@
+cmake_minimum_required(VERSION 2.6)
+cmake_policy(VERSION 2.6)
+
+project(xxhash)
+
+set(XXHASH_LIB_VERSION "0.42.0")
+set(XXHASH_LIB_SOVERSION "0")
+
+add_library(xxhash SHARED ../xxhash.c)
+set_target_properties(xxhash PROPERTIES COMPILE_DEFINITIONS "XXHASH_EXPORT"
+ VERSION "${XXHASH_LIB_VERSION}"
+ SOVERSION "${XXHASH_LIB_SOVERSION}")
+set(install_libs xxhash)
+
+set(BUILD_STATIC_LIBS ON CACHE BOOL "Set to ON to build static libraries")
+if(BUILD_STATIC_LIBS)
+ add_library(xxhashstatic ../xxhash.c)
+ set_target_properties(xxhashstatic PROPERTIES OUTPUT_NAME xxhash)
+ LIST(APPEND install_libs xxhashstatic)
+endif(BUILD_STATIC_LIBS)
+
+
+INSTALL(FILES ../xxhash.h DESTINATION include)
+INSTALL(TARGETS ${install_libs} DESTINATION lib)