summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/drivers/crypto/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/drivers/crypto/meson.build')
-rw-r--r--src/spdk/dpdk/drivers/crypto/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/spdk/dpdk/drivers/crypto/meson.build b/src/spdk/dpdk/drivers/crypto/meson.build
new file mode 100644
index 00000000..d64ca418
--- /dev/null
+++ b/src/spdk/dpdk/drivers/crypto/meson.build
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+drivers = ['ccp', 'dpaa_sec', 'dpaa2_sec', 'mvsam',
+ 'null', 'openssl', 'qat', 'virtio']
+
+std_deps = ['cryptodev'] # cryptodev pulls in all other needed deps
+config_flag_fmt = 'RTE_LIBRTE_@0@_PMD'
+driver_name_fmt = 'rte_pmd_@0@'