summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/examples/ethtool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/examples/ethtool/Makefile')
-rw-r--r--src/spdk/dpdk/examples/ethtool/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/spdk/dpdk/examples/ethtool/Makefile b/src/spdk/dpdk/examples/ethtool/Makefile
new file mode 100644
index 00000000..3d9d4f06
--- /dev/null
+++ b/src/spdk/dpdk/examples/ethtool/Makefile
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2015 Intel Corporation
+
+ifeq ($(RTE_SDK),)
+$(error "Please define RTE_SDK environment variable")
+endif
+
+# Default target, can be overwritten by command line or environment
+RTE_TARGET ?= x86_64-native-linuxapp-gcc
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+ifneq ($(CONFIG_RTE_EXEC_ENV_LINUXAPP),y)
+$(info This application can only operate in a linuxapp environment, \
+please change the definition of the RTE_TARGET environment variable)
+else
+
+DIRS-y += lib ethtool-app
+endif
+
+DEPDIRS-ethtool-app := lib
+
+include $(RTE_SDK)/mk/rte.extsubdir.mk