summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/mk/internal/rte.build-post.mk
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/mk/internal/rte.build-post.mk')
-rw-r--r--src/spdk/dpdk/mk/internal/rte.build-post.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/spdk/dpdk/mk/internal/rte.build-post.mk b/src/spdk/dpdk/mk/internal/rte.build-post.mk
new file mode 100644
index 00000000..a6b6a9a4
--- /dev/null
+++ b/src/spdk/dpdk/mk/internal/rte.build-post.mk
@@ -0,0 +1,34 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2014 Intel Corporation
+
+# build helper .mk
+
+# fast way, no need to do prebuild and postbuild
+ifeq ($(PREBUILD)$(POSTBUILD),)
+
+_postbuild: $(_BUILD)
+ @touch _postbuild
+
+else # slower way
+
+_prebuild: $(PREBUILD)
+ @touch _prebuild
+
+ifneq ($(_BUILD),)
+$(_BUILD): _prebuild
+else
+_BUILD = _prebuild
+endif
+
+_build: $(_BUILD)
+ @touch _build
+
+ifneq ($(POSTBUILD),)
+$(POSTBUILD): _build
+else
+POSTBUILD = _build
+endif
+
+_postbuild: $(POSTBUILD)
+ @touch _postbuild
+endif \ No newline at end of file