summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/test/Makefile')
-rw-r--r--src/spdk/dpdk/test/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/spdk/dpdk/test/Makefile b/src/spdk/dpdk/test/Makefile
new file mode 100644
index 00000000..6656374f
--- /dev/null
+++ b/src/spdk/dpdk/test/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+DIRS-$(CONFIG_RTE_APP_TEST) += test
+DIRS-$(CONFIG_RTE_LIBRTE_ACL) += test-acl
+DIRS-$(CONFIG_RTE_LIBRTE_PIPELINE) += test-pipeline
+DIRS-$(CONFIG_RTE_LIBRTE_CMDLINE) += cmdline_test
+
+include $(RTE_SDK)/mk/rte.subdir.mk